zeldor.biz

Linux, programming and more

Copyright © 2025
Log in

Debian disable IPv6

June 13, 2013 by Igor Drobot Leave a Comment

debian_logo

Since Debian 6 (squeeze) this is the working method to disable permanent IPv6 implementation. This method is also reboot safe.

cat /etc/sysctl.d/disable-ipv6.conf
net.ipv6.conf.all.disable_ipv6=1

cat /etc/sysctl.d/disable-ipv6.conf net.ipv6.conf.all.disable_ipv6=1

If you have no possibility to restart your system yet, this change can be made immediately work by executing:

sysctl -p /etc/sysctl.d/disable-ipv6.conf

sysctl -p /etc/sysctl.d/disable-ipv6.conf

Anothe method – perfect for firewall scripts:

echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

Filed Under: Debian, IPv6, Linux, Networking Tagged With: Debian, Ipv6

Ubuntu ipv6 fail

June 20, 2011 by Igor Drobot 2 Comments

On June 8, 2011 was world IPv6 day and I shared some VPS boxes. Only one guy wants Ubuntu 11.04 – no problem he get it.

I was painfully remembered that Ubuntu.com has still some problems with AAAA record for security.ubuntu.com… They have no records:) [Read more…]

Filed Under: IPv6, Linux, Networking, Ubuntu Tagged With: aptitude, fail, Ipv6, Ubuntu

CCNA Exploration 4 – Module 7

September 28, 2010 by Igor Drobot Leave a Comment

Manual Allocation: The administrator assigns a pre-allocated IP address to the client and DHCP only communicates the IP address to the device.
Automatic Allocation: DHCP automatically assigns a static IP address permanently to a device, selecting it from a pool of available addresses. There is no lease and the address is permanently assigned to a device.
Dynamic Allocation: DHCP automatically dynamically assigns, or leases, an IP address from a pool of addresses for a limited period of time chosen by the server, or until the client tells the DHCP server that it no longer needs the address.

1
2
3
4
5
6
7
R1(config)# ip dhcp exclude-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp exclude-address 192.168.10.254
R1(config)# ip dhcp pool LAN-POOL-1
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default router 192.168.10.1
R1(dhcp-config)# domain-name span.com
R1(dhcp-config)# end

R1(config)# ip dhcp exclude-address 192.168.10.1 192.168.10.9 R1(config)# ip dhcp exclude-address 192.168.10.254 R1(config)# ip dhcp pool LAN-POOL-1 R1(dhcp-config)# network 192.168.10.0 255.255.255.0 R1(dhcp-config)# default router 192.168.10.1 R1(dhcp-config)# domain-name span.com R1(dhcp-config)# end

Configure DHCP address:

1
2
3
Eagle(config)# interface fa0/0
Eagle(config-if)# ip address dhcp
Eagle(config-if)# no shut

Eagle(config)# interface fa0/0 Eagle(config-if)# ip address dhcp Eagle(config-if)# no shut

Configure DHCP relay:

1
2
3
4
R1# config t 
R1(config)# interface Fa0/0
R1(config-if)# ip helper-address 192.168.11.5
R1(config-if)# end

R1# config t R1(config)# interface Fa0/0 R1(config-if)# ip helper-address 192.168.11.5 R1(config-if)# end

Configure Static NAT

1
R2(config)#ip nat inside source static 192.168.20.254 209.165.202.131

R2(config)#ip nat inside source static 192.168.20.254 209.165.202.131

Configure Dynamic NAT Overload

1
2
3
4
5
6
7
8
9
10
R2(config)#ip nat pool R2POOL 209.165.202.128 209.165.202.130 netmask 255.255.255.252
R2(config)#ip nat inside source list R2NAT pool R2POOL overload
 
 
R2(config)#interface Serial 0/1/0
R2(config-if)#ip nat outside
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip nat inside
# optional
ISP(config)#ip route 209.165.202.128 255.255.255.224 serial0/0/0

R2(config)#ip nat pool R2POOL 209.165.202.128 209.165.202.130 netmask 255.255.255.252 R2(config)#ip nat inside source list R2NAT pool R2POOL overload R2(config)#interface Serial 0/1/0 R2(config-if)#ip nat outside R2(config)#interface fastEthernet 0/0 R2(config-if)#ip nat inside # optional ISP(config)#ip route 209.165.202.128 255.255.255.224 serial0/0/0

IPV6 Dual Stack Configuration:

1
2
3
4
5
conf t
pv6 unicast-routing
interface ethernet0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:470:1f0b:1514::7/64

conf t pv6 unicast-routing interface ethernet0 ip address 192.168.99.1 255.255.255.0 ipv6 address 2001:470:1f0b:1514::7/64

IPV6 Routing:

1
2
3
4
5
Router(config)# ipv6 unicast-routing
Router(config-if)# ipv6 address ipv6prefix/prefix-length eui-64
 
DNS Resolver:
ip name-server 2001:470:1f0b:1514::1

Router(config)# ipv6 unicast-routing Router(config-if)# ipv6 address ipv6prefix/prefix-length eui-64 DNS Resolver: ip name-server 2001:470:1f0b:1514::1

Filed Under: Cisco, Networking Tagged With: CCNA-4, Cisco, Cisco Academy, DHCP, Ipv6, NAT, PAT

FTP over IPv6

September 4, 2010 by Igor Drobot Leave a Comment

The standard ftp command/client does not support IPv6 resolution.

A very powerful IPv6 ftp client alternative is lftp.

1
2
3
id@acer:~$ lftp ipv6.idrobot.net
lftp ipv6.idrobot.net:~> dir
-rw-r--r--   1 ftp      ftp             0 Aug 26 17:28 test.txt

id@acer:~$ lftp ipv6.idrobot.net lftp ipv6.idrobot.net:~> dir -rw-r--r-- 1 ftp ftp 0 Aug 26 17:28 test.txt

And of course Firefox does FTP over IPv6:
ftp://ipv6.idrobot.net OR ftp://[2a01:4f8:131:51e2::10]

Filed Under: FTP, IPv6, Linux, Networking Tagged With: FTP, ftp ipv6, Ipv6, lftp ipv6

Postfix with IPv6

September 3, 2010 by Igor Drobot Leave a Comment


In this how to I describe the basically configuration and administration of Postfix on Debian Lenny.
Current I’m using Postfix version 2.5.5
This tutorial should working with older and newer versions.

1
2
postconf -d | grep "mail_version =" | cut -d" " -f 3
2.5.5

postconf -d | grep "mail_version =" | cut -d" " -f 3 2.5.5

You can find the postfix main configuration file under “/etc/postfix”
Let see what wee need to configure a working Internet Mail-Server

1
postfix ~ # vim /etc/postfix/main.cf

postfix ~ # vim /etc/postfix/main.cf

My example configuration:

1
2
3
4
5
6
7
8
9
10
11
12
13
myhostname = ipv6.postfix.idrobot.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = ipv6.postfix.idrobot.net, localhost.localdomain, localhost
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
smtp_bind_address6 = 2a01:4f8:101:265::37
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
home_mailbox = Maildir/
bounce_template_file = /etc/postfix/bounce.cf

myhostname = ipv6.postfix.idrobot.net alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases mydestination = ipv6.postfix.idrobot.net, localhost.localdomain, localhost mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 smtp_bind_address6 = 2a01:4f8:101:265::37 mailbox_command = mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all inet_protocols = all home_mailbox = Maildir/ bounce_template_file = /etc/postfix/bounce.cf

If you want to relay your mails to another mail-server you can use the relayhost option:
Edit main.cf, and add this line:

1
relayhost = ipv6.mx.idrobot.net

relayhost = ipv6.mx.idrobot.net

Some administration commands:
Show running config:

1
postconf -n

postconf -n

Show the default postfix config instead of running one:

1
postconf -d

postconf -d

Show message content:

1
postcat -q 7FB942082

postcat -q 7FB942082

Delete all mail in queue:

1
postsuper -d ALL

postsuper -d ALL

Schedule immediate delivery:

1
postqueue -i 7FB942082

postqueue -i 7FB942082

Flush the queue:

1
postqueue -f

postqueue -f

Filed Under: Debian, IPv6, Linux, Mailing, Networking Tagged With: Ipv6, MTA, Postfix, Postfix ipv6

  • 1
  • 2
  • 3
  • Next Page »
Yeaaah Cookie! We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.Ok