zeldor.biz

Linux, programming and more

Copyright © 2023
Log in

Rsync over SSH

January 19, 2014 by Igor Drobot Leave a Comment

Rsync over SSH

In some special cases is a VM accessible over NAT and on different port as usually 22.
In this case – SSH is running on port 222.
This make the rsync operation little bit complexer:

1
rsync -vraze 'ssh -p 222' root@remote:/source/ /destination/

rsync -vraze 'ssh -p 222' root@remote:/source/ /destination/

Filed Under: Linux Tagged With: NAT, rsync, ssh

Vodafone easybox 802

October 9, 2011 by Igor Drobot 4 Comments

Some days ago I got a new ADSL2+ connection from a new ISP(1und1). Of cource I get a hardware package with brand new 1und1 homeserver, the real product behind this name is a FRITZ!Box 7320.

The first problem was [Read more…]

Filed Under: Networking Tagged With: DSL-Modem, easybox 802, fritz box, MTU, NAT, PMTUD, Vodafone

CCNA Exploration 4 – Module 7

September 28, 2010 by Igor Drobot Leave a Comment

Manual Allocation: The administrator assigns a pre-allocated IP address to the client and DHCP only communicates the IP address to the device.
Automatic Allocation: DHCP automatically assigns a static IP address permanently to a device, selecting it from a pool of available addresses. There is no lease and the address is permanently assigned to a device.
Dynamic Allocation: DHCP automatically dynamically assigns, or leases, an IP address from a pool of addresses for a limited period of time chosen by the server, or until the client tells the DHCP server that it no longer needs the address.

1
2
3
4
5
6
7
R1(config)# ip dhcp exclude-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp exclude-address 192.168.10.254
R1(config)# ip dhcp pool LAN-POOL-1
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default router 192.168.10.1
R1(dhcp-config)# domain-name span.com
R1(dhcp-config)# end

R1(config)# ip dhcp exclude-address 192.168.10.1 192.168.10.9 R1(config)# ip dhcp exclude-address 192.168.10.254 R1(config)# ip dhcp pool LAN-POOL-1 R1(dhcp-config)# network 192.168.10.0 255.255.255.0 R1(dhcp-config)# default router 192.168.10.1 R1(dhcp-config)# domain-name span.com R1(dhcp-config)# end

Configure DHCP address:

1
2
3
Eagle(config)# interface fa0/0
Eagle(config-if)# ip address dhcp
Eagle(config-if)# no shut

Eagle(config)# interface fa0/0 Eagle(config-if)# ip address dhcp Eagle(config-if)# no shut

Configure DHCP relay:

1
2
3
4
R1# config t 
R1(config)# interface Fa0/0
R1(config-if)# ip helper-address 192.168.11.5
R1(config-if)# end

R1# config t R1(config)# interface Fa0/0 R1(config-if)# ip helper-address 192.168.11.5 R1(config-if)# end

Configure Static NAT

1
R2(config)#ip nat inside source static 192.168.20.254 209.165.202.131

R2(config)#ip nat inside source static 192.168.20.254 209.165.202.131

Configure Dynamic NAT Overload

1
2
3
4
5
6
7
8
9
10
R2(config)#ip nat pool R2POOL 209.165.202.128 209.165.202.130 netmask 255.255.255.252
R2(config)#ip nat inside source list R2NAT pool R2POOL overload
 
 
R2(config)#interface Serial 0/1/0
R2(config-if)#ip nat outside
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip nat inside
# optional
ISP(config)#ip route 209.165.202.128 255.255.255.224 serial0/0/0

R2(config)#ip nat pool R2POOL 209.165.202.128 209.165.202.130 netmask 255.255.255.252 R2(config)#ip nat inside source list R2NAT pool R2POOL overload R2(config)#interface Serial 0/1/0 R2(config-if)#ip nat outside R2(config)#interface fastEthernet 0/0 R2(config-if)#ip nat inside # optional ISP(config)#ip route 209.165.202.128 255.255.255.224 serial0/0/0

IPV6 Dual Stack Configuration:

1
2
3
4
5
conf t
pv6 unicast-routing
interface ethernet0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:470:1f0b:1514::7/64

conf t pv6 unicast-routing interface ethernet0 ip address 192.168.99.1 255.255.255.0 ipv6 address 2001:470:1f0b:1514::7/64

IPV6 Routing:

1
2
3
4
5
Router(config)# ipv6 unicast-routing
Router(config-if)# ipv6 address ipv6prefix/prefix-length eui-64
 
DNS Resolver:
ip name-server 2001:470:1f0b:1514::1

Router(config)# ipv6 unicast-routing Router(config-if)# ipv6 address ipv6prefix/prefix-length eui-64 DNS Resolver: ip name-server 2001:470:1f0b:1514::1

Filed Under: Cisco, Networking Tagged With: CCNA-4, Cisco, Cisco Academy, DHCP, Ipv6, NAT, PAT